
FILE MANAGER
EVEN THE MOST GLORIOUS EDIFICE HAS ONE FACADE THAT ISN'T AS GRAND AS all 
the others. Even the best hitter in baseball has a particular pitch he's weak at. For 
Windows, the weak aspect is unquestionably File Manager, the program that allows 
you to manage files, directories, and disk drives.

In Windows 3.0, File Manager was so bad it was the single biggest reason, we 
feel, that Windows users reported spending a fair amount of time back in character-
mode DOS. It was easier to mash that DOS button and do it the old way than to face 
the rigors of File Manager.

In Windows 3.1, File Manager has been hugely improved, which is to say that 
now it's barely adequate. It's inscrutable, rather than confounding.

When it comes to File Manager you have three choices: One, you can bag it 
and drop to DOS for your file operations, which is like reverting to bike pedals for 
getting your Ferrari uphill. Two, you can check out one of the many commercial 
alternatives to File Manager. It's a given in the PC business that any weakness in a 
popular program will draw potential replacement programs like a trash can draws 
flies. Your third choice is the courageous one: Dig in and work with File Manager. Use 
the extensibility and customizability of Windows to improve File Manager to suit your 
tastes. That's what we've done. To make your journey into the File Manager jungle 
easier (and a lot less time-consuming) than ours was, we offer here a veritable road 
map of shortcuts and suggestions for taming the wild subdirectory and handling 
other such adventures of the Windows outback.

File Manager Housekeeping
The essential reason for the File Manager's existence is the selection, movement, and
manipulation of the files stored on your PC. In DOS, this was all done at the command
line, a process that was remarkably swift if you knew your way around the 
commands, and utterly impenetrable if you didn't. By replacing commands with 
mouse clicks and the command line with graphics displays, the File Manager has 
greatly simplified these processes for the uninitiated, and hugely slowed them down 
for the expert. But remember, you can always drop back down to the DOS prompt for 
file handling if you're a DOS guru. With the techniques offered here though, you may 
find File Manager performance improved enough to be acceptable.

Selecting Files 
In DOS, you could manage a single file reasonably, and handling a complete directory
wasn't too hard. But working with groups of files smaller than a whole directory was a
major headache under DOS. Whole products were created to fill this gap. Under 
Windows, the File Manager makes it possible to select different sets of files, but 
leaves the process a bit confusing. Try these ideas to make file selection smoother.

Fast File Manager Selections Windows' File Manager offers a couple of 
mouse shortcuts for file selection. To select a contiguous group of files, point to the 
first filename and then hold down the Shift key while clicking on the filename at the 
end of the group. If you want to select a group of files that are not contiguous, hold 
down the Ctrl key as you point to each filename in the File Manager directory window,
and click with the left mouse button. You can also use this trick to deselect individual 
files in a group if you change your mind.

Selecting Even More Files in the File Manager Making multiple file
selections in File Manager is straightforward enough: Just press Shift and click on 
filenames to highlight contiguous files or subdirectories, or press Ctrl and click for 



noncontiguous selections. However, here are some even easier ways for quick file or 
subdirectory processing. Press Shift+F8 to enable the selection cursor-a blinking, 
dotted line that lets you select any number of files by first pressing the spacebar on 
the file to select it and then using the arrow keys to advance to the next file. To select
all files in a subdirectory, press Shift+slash (/). To copy all the highlighted files at 
once, drag the mouse from one of the highlighted files to another disk drive or 
subdirectory.

The Sort by Type and By File Type Options Are Different 
Here's something to keep in mind: The File Manager's View menu options (Sort by 
Type and By File Type) are quite different. When you select Sort by Type, you get a list
of files sorted by extension. Files with no extension come first and then the other 
files, in alphabetical order by extension. Selecting By File Type gives you much more 
power. Clicking this option displays the dialog box shown in Figure 7.1, which lets you
choose the files you want to display. Check Programs and you'll see just program files
(such as *.COM, *.EXE or *.PIF files). Check Documents and you'll see only files with 
extensions associated with applications. You can even request to see ordinarily 
hidden system files. Select as many file type options as you wish.

Caveats When Viewing by File Type One big limitation to viewing by file 
type is how confusing it can get. When you select a subset of files to view, File 
Manager gives no indication that this isn't your complete directory listing. If you exit 
File Manager with this display, and you have checked Save Settings on Exit, the 
subset screen will return when File Manager is reloaded. Even if you press the F5 key,
which forces File Manager to reread the disk, the display will not change.

Believe it or not, Windows has no natural way around this problem. But there 
is one (and apparently only one) approach that works. To get back to your complete 
directory listing after viewing by file type, first make sure that Name and Sort by 
Name are checked on the View menu. Then select By File Type again. Make sure that 
*.* appears in the Name box and that Directories, Programs, Documents, and Other 
Files have all been checked under File Type. Choose OK, and you'll get your complete 
listing back.

Quickly Collapsing the Directory Tree  File Manager provides a 
keyboard shortcut for expanding all the branches of your directory tree (Shift+*), but 
doesn't have a keyboard shortcut to collapse them. You can, however, accomplish 
this with your trusty mouse. Double-click on the root directory. The entire directory 
tree will disappear from the directory tree window, and all you'll see is the root 
directory. Double-click on it again to reveal its directories, but not their 
subdirectories. You can use this mouse shortcut to collapse individual directories as 
well.

File Tweaks and Traps
Once created, files have a habit of never staying still. They need to be copied, saved, 
protected, archived, and otherwise altered across their natural lives. As with so many 
areas, the File Manager handles these chores, but somewhat less than elegantly. 
Avoid much mouse clicking and mouth cursing by using these tips.

File Naming for Efficiency Here's a simple time saver: File Manager 
always places files that begin with numerals at the beginning of its displays. After 
that, it sorts alphabetically by first letter, unless you give other instructions. So, give 
files you access often names that begin with numerals, such as 1GETIT.COM or 
1DOS.PIF. That way, these filenames will always top your directory listings. Also, 
name files you want grouped together with the same first letter.



Hide Files from File Manager (and Yourself) File Manager helps 
prevent you from accidentally deleting or changing important files by enabling you to
mark files as read-only. But these read-only files can still be deleted like any other 
files, even though Windows brings a dialog box asking if you in fact want to delete 
the file, as shown in Figure 7.2 (unless you have turned off this option by selecting 
Confirmation from the Options menu and checking the appropriate check box). 
Increase the protection of these important files by also hiding them from view. If you 
can't see them, chances are you won't accidentally delete or rewrite them. Hiding 
critical files can also keep them away from prying eyes.

You can set a file's attributes to read-only and hidden at the same time. Select
the name of the file, choose Properties from the File menu, check the Read-Only and 
Hidden check boxes, and then choose OK. To ensure that these files won't be visible 
in File Manager, choose By File Type from the View menu and make sure that the 
Show Hidden/System Files box is not marked.

NOTE If you use File Manager's Search feature, it will find hidden as well as 
nonhidden files that match the search description.

You can also apply this technique to entire subdirectories. If you share a PC 
with other users, you may want to mark the subdirectory where you store your files 
as hidden, but not read-only.

Copy Files within the Same Drive If you select a file and drag it to 
another directory located on the same drive, Windows asks if you want to move the 
file to the new location. If you want to place a copy of the file in the new directory but
still retain the old one, you have to hold down the Ctrl key while you drag the file. A 
confirmation box still appears, but this one correctly asks if you want to copy the file 
to the new directory.

Refreshing Floppy Drive Listings It can be frustrating to get an accurate 
file listing of a floppy disk in File Manager unless you know which command to issue. 
For example, if you review the contents of one floppy disk and can't find the file you 
are looking for, you'll try another floppy disk. But when you click the drive icon for the
disk drive, for example B:, all you get is the listing from the first disk. Windows is 
showing you the directory it has stored in memory for that drive; it is not reading the 
drive anew. You can try closing the window and reselecting the drive icon, but to no 
avail; you'll still see the contents of the previous floppy disk. Even switching 
temporarily to another disk drive doesn't do the trick. Short of exiting from File 
Manager and starting it all over again, what can you do?

Actually, the answer is quite simple and will make you wonder why you spent 
all that time trying to get an accurate floppy listing! Just press the F5 key or choose 
the Refresh command from the Window menu. Voilà! An updated listing of the current
floppy disk. Repeat the command every time you insert a new floppy disk into the 
drive.

Copy and Move Files to Floppies If you need to copy a file from one drive 
to another, for example, from your hard disk to a floppy, you simply drag the 
filename to the drive icon and release it. But what if you want to move the file 
instead? Holding down the Alt key while you drag the file tells Windows that you want
to put the file in a new location altogether, rather than creating another copy of it. If 
you have selected the Mouse Action option (Windows 3.1) or Mouse Operation option 
(Windows 3.0) in the Confirmation dialog box, Windows will ask if you do indeed want 
to move the file to the new location, as shown in Figure 7.3.



Search Out Temporary Files If you're having trouble locating a file or group 
of files because your directories and subdirectories contain so many of them, use File 
Manager's Search feature. You can tell Search to look for specific words, file 
extensions, or even wildcards.

Put this capability to work by using it to rid your hard disk of old temp files 
that may be lurking about. Windows is supposed to delete these temp files when it's 
done with them, but any Windows user can tell you that that's not always the case. 
Before you select the Search option, make sure that the root directory is selected so 
that you can search the entire disk drive. Also, select Partial Details from the View 
menu and check Last Modification Date. Choose Search from the File menu, and mark
the Search All Subdirectories box (if not already marked). In the Search For box, type 
*.tmp. File Manager then gives you a listing of all these files, as you can see in Figure
7.4. Because you asked for last modification date, the list will be sorted by the date 
of last usage. If the file dates are old, go ahead and delete them from within 
Windows, but if the files are from your current session leave them alone!

A Caution on Searches Only move files from a Search Results window with the
mouse. If you drag a file into or out of this window, it will update to include the 
change. However, if you do the same operation using keystrokes, the Search Results 
window will not automatically reflect the changes.

Search Multiple Layers Remember that you can search a set of files multiple
times. This means that you can search for a preliminary set of files that meet one 
criterion and then search that subset for a second pattern. In this way you can 
pinpoint your searches and keep to a minimum the wait while File Manager pores 
over your directories.

Use View to Find Files by Date If you want to place the files that you 
have altered most recently first, select Sort by Date from the File Manager's View 
menu. If you want to see the dates the files were saved, check Partial Details on the 
View menu. Then, in the Partial Details dialog box, shown in Figure 7.5, check Last 
Modification Date.

File Manager's Quick Deletes The File Manager's default settings for 
deleting files are wisely geared for the cautious, but the constant query "Delete 
file...?" can be annoying if you have entire subdirectories to clear. To remove the 
safety net and shave minutes off your file management chores, select File Manager's 
Options menu and choose Confirmation. If you delete multiple files in the same 
subdirectory, click on the first option, File Delete, to deselect it. If you're going to 
remove whole nested subdirectories, click on the second option, Directory Delete, to 
deselect it. To play it safe again once you've deleted your files, reselect both options, 
or make sure that Save Settings on Exit is not checked in the File Manager Options 
menu.

Printing Directory Listings from File Manager Windows' File 
Manager doesn't provide a way to print directory listings, but you can create a batch 
file that will do the job. Using a text editor such as Notepad, create a one-line batch 
file like the following (substitute your printer port for LPT1 if it is different):

 DIR %1 > LPT1

Save the file with a name like PRINTDIR.BAT, and make sure that it is located in a 
directory that is in your PATH statement. Now when you want to print a directory 



listing from File Manager, choose the Run command from the File menu and type 
printdir.bat (or whatever you named the batch file) followed by the desired 
directory in the Command Line text box. For example, to get a listing of your 
REPORTS directory, type

 printdir.bat c:\reports

A DOS screen will appear and then disappear as the directory listing is sent to the 
printer.

Another, somewhat quicker option for the DOS savvy is to select Run from the 
File Manager's File menu. In the Command Line text box of the resulting dialog box, 
type

 command.com /c dir> lpt1

This runs a copy of COMMAND.COM, the DOS command processor, and orders it to 
print your directory listing on printer LPT1.

The only limitation of this trick is if you have a .PIF file for DOS called 
COMMAND.PIF. If you do, that file, not a native COMMAND.COM, will run here. An easy
fix is to instead name your DOS-session .PIF file DOS.PIF.

Finding File Facts Fast When a file or directory is selected in File Manager, 
you can press Alt+Enter to call up a Properties dialog box that gives you detailed file 
information. The dialog box includes the filename, file size, last modification date, 
path, and file attributes, as shown in Figure 7.6.

Get More Information on All Files  Usually, File Manager only lists file 
and directory names. However, you can instruct it to tell you far more about your 
files. From the View menu, select All File Details. Now your listings should include 
name, size in bytes, date and time last modified, and all file attributes for every file. 
Too much info? Go back and check Partial Details from the View menu instead. Now 
you'll see a dialog box (shown earlier, in Figure 7.5) that lets you select what 
information you want on your files. The information you select here will remain in 
force for all files until you uncheck this choice on the View menu. If you have Save 
Settings on Exit selected, this will become your default listing.

Starting Programs from the File Manager You can start programs from 
the File Manager in one of several ways:

Double-click on a selected program's File Manager icon or on the icon of a document 
associated with the application (for more on association see "Take Advantage of 
Associations," later in this chapter).

Drag the icon for an associated document onto the icon of its application.

Select Run from the File menu, and enter the application's startup command into the 
Run dialog box.

Select an associated document and press Enter or click on Open in the File menu.

Some Windows applications offer still other options, such as dragging an 
associated document icon into an open application window or onto the application's 
title bar. The preceding options should work for every Windows application.



Starting DOS Programs from the File Manager You can also start DOS 
programs from the File Manager, as long as you have created .PIF files for them. 
Open a window on the WINDOWS directory on your C drive (or wherever you have 
Windows loaded). Double-click on the .PIF file for the DOS program you want; it will 
run.

Installing Windows Programs with the File Manager Install 
applications in Windows through the File Manager by double-clicking on the 
application's startup file. To find this file, open the application's directory, select By 
File Type from the View menu, check Programs in the dialog box, and uncheck the 
other three check boxes. Study the resulting list for a file with a name like 
STARTUP.EXE or INSTALL.EXE. Click on this program and the application's setup 
routine will run.

The Fast Way to Change the Active Drive Even quicker than clicking on
a drive icon is changing the active drive in File Manager by pressing Ctrl+drive letter. 
For example, to see a listing of the contents in your A drive, press Ctrl+A.

Quick Formats You don't have to exit to DOS to format floppy disks, because 
Windows 3.1's File Manager lets you do so through its Disk menu. Speed up the 
process of formatting a floppy by selecting the Quick Format option in the Format 
Disk dialog box shown in Figure 7.7 (select Format Disk from the Disk menu). This 
process is faster than a regular format because it does not check the disk for bad 
sectors. Quick Format only works with disks that have been previously formatted. Use
it when you are sure that the disk is problem-free (that is, it has been recently 
formatted and is fairly new) so that you don't end up saving a file to a bad disk sector
and losing important information.

Minimizing File Manager for Quick Access Minimizing makes sense for
any Windows application you think you'll use later, but it's particularly valuable with 
the File Manager. Every time you load File Manager, it reads your entire disk 
structure, wasting precious time. If you minimize it instead of closing it on first use, 
you can get back to the File Manager much faster by using the Task List or by clicking
on the File Manager icon.

If you want to make this process automatic, pull down the File Manager 
Options menu and check Minimize on Use. Then put a copy of the File Manager in 
your StartUp program group. A minimized File Manager will appear each time you 
start Windows.

Using File Manager for Daily Backups Use the File Manager for a quick 
daily backup of each day's work to a floppy disk. In the Options menu, select 
Confirmation and make sure each box in the dialog box has been checked so that you
won't have to okay any overwriting of old versions of today's files. Then, before you 
end your work, go to the File Manager and open whatever directory you've worked in.
Select Sort by Date from the View menu. You'll see your new files at the beginning of 
the directory listing. Select these files by clicking to select the first one and then 
holding down the Shift key while clicking on the last file name. Click on Copy from the
File menu (or press F8). In the dialog box, note the drive and directory you want the 
files saved to, as shown in Figure 7.8. Make sure to uncheck File Replace after your 
backup, so you don't inadvertently overwrite files during your other work.

Take Advantage of Associations
One of the many conveniences Windows offers you is the ability to load a data file 
and the program that created it by simply double-clicking on the data file's icon.



The trick is in the data file's extension. Windows rides atop DOS and uses 
DOS's outdated file system, so data files don't automatically reveal which programs 
created them, as Macintosh files do. But Windows can be taught to associate certain 
file extensions with specific programs. For example, for Windows to open 
NOTEPAD.EXE anytime you double-click on a file with the extension .TXT, Windows 
must first be told that all .TXT files belong to Notepad. Fortunately, many applications
provide Windows with linkage information when you install them, and those that 
don't can still be linked to their data files by means of a simple procedure in the File 
Manager. Once files are associated, they take on new powers that you can use to 
manage your system more efficiently.

Establishing Associations To establish an association, follow these steps:

1.Run File Manager, either by double-clicking on its icon in Program Manager or by 
pulling down Program Manager's File menu, choosing Run, and typing winfile.

2.Find a file that has the extension that you want to associate, for example *.XYZ. 
You'll notice that next to it (and all the other filenames) is a small icon, as shown in 
Figure 7.9. Document and data files, such as this one, are marked by rectangles with 
a bent corner.

3.Pull down File Manager's File menu and choose the Associate command. A dialog 
box like the one shown in Figure 7.10 appears.

4.In the text box at the top, you enter the file extension you want to associate.

5.At the bottom is a list of the various applications you can associate the file with. 
Select one and click on OK.

All files that have the specified extension will now be associated with that application.
That's all there is to it!

When you click on OK in the Associate dialog box, all of the icons next to 
the .XYZ files instantly change. They're still dog-eared, but they now bear little black 
stripes. A striped, dog-eared icon denotes a document file associated with a program.
This means that any .XYZ file that you select (not just the specific one that you 
associated) can be launched from File Manager.

Change Predefined Associations File Manager can run a program and open
an associated file when you click on the file's name, but it doesn't always work the 
way you want. If you want to look at .PCX files in Publisher Paintbrush, for example, 
the default association to the Windows Paintbrush accessory won't help you. 
Fortunately, creating and editing file associations is simple. Select a data file's name 
from any open subdirectory in File Manager, and then select the File menu's 
Associate option. Enter the path and filename of the program you want to open when
you double-click on the filename and then press Enter or click on OK. (To find the file 
name, you can use the Browse button in the Associate dialog box. It displays the 
dialog box shown in Figure 7.11.) To get a list of existing file associations, open your 
WIN.INI file and scroll the [Extensions] section. You can also associate files and 
applications by directly editing the WIN.INI yourself. This is discussed in more detail in
Chapter 2.

Quick Check for Associated Files If you double-click on the icon of a data
file that is not associated with a program, you'll receive a message to that effect. To 
avoid getting this dialog box, you can do a quick check before you double-click on the



file icon. The icon next to the filename will be blank if it is not associated; if it is 
associated you will see little lines across the icons, as shown in Figure 7.12.

Loading an Unassociated Data File If a data file is not associated with an 
application, you can still run it from File Manager. Select the file and then drag it and 
release it on top of the executable file for that application. Windows will ask if you 
want to start the application with that specific file, as shown in Figure 7.13. Select Yes
and the application will start with the file loaded.

For example, to start the Word for Windows document file MYNOTES.DEC, drag
it and release it onto the file WINWORD.EXE. To carry out this dragging and dropping 
operation, it's probably easiest to display two tiled directory windows if the document
file and application file are not located in the same directory (as in Figure 7.13).

NOTE Make sure both the file you want to drag and the executable file you want to 
drop it on are visible on screen before you begin the process. You can't scroll through 
a directory window while dragging a file.

Quicker File Manager Access in Windows 3.0 Getting to the File 
Manager takes considerably more time in Windows 3.0 than in Windows 3.1 because 
the old version of File Manager reads the directory contents of the entire active drive 
when it loads. In Windows 3.1, this time-consuming behavior is eliminated. If you 
haven't upgraded to Windows 3.1 and don't like waiting for File Manager to cycle 
through the drive, you can gain control of File Manager more quickly by using a 
variation on the procedure described in the previous section.

Select the File Manager icon from the Program Manager's Main program group.
Pull down the File menu and select Properties. In the Program Item Properties dialog 
box for your File Manager icon, change the path from C:\WINFILE.EXE to point to a 
drive on your system that contains fewer directories and files. An excellent candidate 
is a RAM drive, if you have one, because it contains few files. For example, for a RAM 
drive D, the new command line would read D:\WINFILE.EXE. Windows will tell you that
the path is invalid, but just select OK to make it accept the changes.

Getting the Most from Windows 3.1 File 
Manager
If this were a book about Windows 3.0 exclusively, this section wouldn't exist. That's 
because the Windows 3.0 File Manager was so weak the problem was getting it to 
work, not getting the greatest benefit from it. Under Windows 3.1, however, the File 
Manager is solid enough to offer some worthwhile tricks for the savvy user, such as 
those that follow.

File Manager Drag and Drop Techniques
One of the great boons of the File Manager, once you get the knack of it, is the ability
to replace typed or menu-driven file operations with simple drag and drop on-screen 
procedures. The notion of literally taking a file from here and putting it there makes 
eminent sense.

Drag and Drop Basics In File Manager, you can move or copy files by simply 
dragging their icons from one spot and dropping those icons on another with the 
mouse. You control what happens when you drag an icon by the key you hold down 
while moving the mouse. Here are the basic combinations:

Action    Result



Drag (no key pressed) Moves a file among directories of a single drive or copies a 
file between drives or into any Program Manager group (since this doesn't actually 
move the file, just the icon)

Drag+Shift or Moves a file between drives
Drag+Alt 

Drag+Ctrl Copies a file on a single drive or between drives

You Don't Need Open Windows to Drag and Drop You can move and 
copy between open directory windows, but you don't have to. You can drag and drop 
to a minimized directory window, to a folder icon in a directory tree window, or to a 
disk drive icon. If you use a
minimized directory of a disk drive icon, the dragged files will go into the logged 
directory.

Combine Associations with Drag and Drop If a file extension is 
associated with a file type defined in Windows 3.1's Registration Database, not only 
can you start the application (as in Windows 3.0), but you can also print the file, add 
its icon to a Program Manager group, and even embed the file in another document 
all by dragging and dropping. We talk about these particular tricks in Chapters 8 and 
9 and elsewhere in this chapter. Here, we'll deal with the basics of the Registration 
Database itself.

The Registration Database, new to Windows 3.1, contains a listing of the file 
types that Windows recognizes. To register a file type, you need to run the utility 
Registration Info Editor by typing regedit in the File Manager's Run dialog box (select
Run from the File menu). To add a new file type, select Add a File Type from the Edit 
menu. A dialog box like the one shown in Figure 7.14 will appear, which you then fill 
out for the application. Before you attempt to add an application's file type to the 
Registration Database, you should make sure that the application supports drag and 
drop capabilities. You also need to find out the macro commands and command-line 
options supported by the application so that you can properly fill out the information 
in the Registration Info Editor. Check your application's documentation or contact the 
manufacturer for this information.

Immediate Drag and Drop Add copies of the File Manager and Print Manager 
icons to your StartUp group so that they'll be readily available. With many 
applications now supporting drag and drop printing, you'll want to keep these two 
managers around all of the time to take advantage of this feature. We'll cover 
printing tricks in detail in Chapter 8. 

Drag and Drop to Nowhere If you change your mind about a drag and drop 
operation after you have selected files and started moving them, simply drag them 
anyplace on the screen that isn't a directory window. This will cancel the procedure 
and return the files to their original spot.

Taming the File Manager Screen
At first, the notion of being able to view all files and directories on the screen sounds 
great. Think about it for a minute, though. Add to an already crowded Windows 
screen the wealth of information contained in a complex scheme of directories and 
subdirectories and you wind up with a visual nightmare. To be most effective, the File 
Manager's screen displays must be carefully managed.



Make File Manager Easier to Read Another new feature of the Windows 
3.1 File Manager is that you can change the font that is used to display the file and 
directory listings. You can enlarge the font so that it's easier to make out individual 
files in crowded directories, or you can decrease the font size to fit more information 
on the screen at one time. You can even change the style of the font, such as making 
it uppercase or boldfaced. For instance, a large, boldfaced font in uppercase may be 
helpful for those who are visually impaired.

To change the File Manager font, select Font from the Options menu to call up 
the Font dialog box seen in Figure 7.15. You'll see the selection of your installed fonts 
that Windows recognizes as potential system fonts, as well as available point size and
format options. Make your selections and click on OK. Your fonts will change 
immediately.

NOTE Your font changes will remain in effect after you exit File Manager, even if you 
haven't checked Save Settings on Exit. To restore your original fonts, you'll have to 
reselect them from the Font dialog box.

Resize File Manager Window Panes Using your mouse, you can easily 
change the proportions of the directory tree pane and the directory contents pane. 
Grab the line that divides the window into these two sections (it's located just to the 
right of the scroll bar) and drag it to the left or right, depending on which side you 
want to make bigger or smaller. See Figure 7.16, in which the size of the directory 
tree pane has been greatly reduced. If you don't have many branching 
subdirectories, you probably have extra space on the directory tree side. Move the 
border line so that the space can be used to display more files on screen at one time.
Once you adjust the width of these panes, make sure that the Save Settings on Exit 
option is selected so that the newly sized window will remain in place the next time 
you use File Manager.

Control the Files You See in Windows Getting multiple directory 
windows open in the File Manager can be confusing. If you click on New Window in 
the Window menu, you get a replica of whatever window is already open. You can 
then work with that window to look at something new. But how inefficient! Here's a 
method that's much better.

When you want to open a new window from the same drive as the one you 
already have on screen, but with a different directory listing, highlight the directory 
folder you want. Press Shift while double-clicking on the highlighted folder. You'll get a
new window that displays that directory. If you want to open a new window onto a 
new drive, just double-click on the drive's icon.

Get Rid of the Directory Tree File Manager defaults to a two-window 
arrangement: one window with the directory tree for the drive, and the other with the
contents of the selected directory. Unless you are planning to hunt around on the 
drive a great deal, the tree listing may be superfluous. You can get rid of it, and 
simplify your File Manager screens, in two ways. To get rid of the tree temporarily, 
use your mouse to grab the slide bar that separates the windows. Drag it all the way 
to the left, covering the tree. If you want the tree removed permanently, go to the 
View menu and click on Directory Only.

To move around without the tree, click on any directory or subdirectory to 
open it; to move to the next highest level in the directory tree, click on the bent 
arrow at the top of any open listing or press Home+Enter.

Put File Windows Side by Side Windows 3.1 enables you to view the 
contents of two drives at once. To do so, select the Tile command from the Window 



menu. When you do this, you'll notice that the two drive windows are stacked 
horizontally. To make the windows line up next to one another so that you can easily 
compare the contents, press Shift+F4 or hold down the Shift key while you choose 
Tile from the Window menu.

Side-by-Side Windows for Drag and Drop The most efficient way to 
arrange windows, if you plan to move many files from one directory or drive to 
another, is side by side. That way you can easily drag your files over to their new 
location. To get two File Manager windows arranged in this way, first press Shift while 
double-clicking on the first directory's icon. This opens a window for that directory. 
Repeat the process for the second window (or refer to the earlier section in this 
chapter, "Control the Files You See in Windows"). When both windows are open, press
Shift+F4 to tile them. Now they will be side by side, and you can easily drag your files
between them.

Put File Manager and Program Manager Side by Side Positioning File
Manager and Program Manager side by side is a bit trickier. The File Manager Tile key 
sequence won't work. What to do? Call up the Windows Task List by clicking any open
space on the desktop or by pressing Ctrl+Esc. Click on the Tile button in the Task List 
dialog box. This will place the Program Manager and File Manager windows side by 
side, as shown in Figure 7.17.

Use File Manager as Your Primary Shell With all of these File Manager 
improvements, you might find yourself working very well in this improved shell. And if
you liked the good old days of the MS-DOS Executive, try using the File Manager 
instead of Program Manager as your primary shell. The File Manager in Windows 3.1 
is about twice as fast as the File Manager in Windows 3.0. And if you get rid of the 
directory tree window by selecting the View menu and choosing Tree Only, it even 
looks and feels the same as the old Windows 2 shell, MS-DOS Executive.

File Manager Keyboard Shortcuts
One way to effectively manage the File Manager screen display is to use keyboard 
shortcuts to move around in File Manager windows as quickly as possible. Table 7.1 
lists the File Manager keyboard shortcuts. 

TABLE 7.1 Keyboard Shortcuts for File Manager

Home Goes to the root directory in the directory tree window or first file in the 
directory list.
End Goes to the last directory or last file in the list.
PgUp Goes to the first visible file or directory in the current window.
PgDn Goes to the last visible file or directory in the current window.
Letter Goes to the next file or directory whose name starts with the specified letter.
Ctrl+/ Selects all files and directories in a directory window.
Ctrl+\ Deselects all files and directories in a directory window.
F5 Refreshes the listing in a directory window.
F7 Moves a selected file or files to the destination you note.
F8 Copies a selected file or files to the destination you note.
Backspace Selects the parent directory or current directory.
Spacebar Selects or deselects a file or directory when choosing files not listed 
contiguously.
Del Deletes a selected file (upon confirmation).
Ctrl+letter Selects the specified disk drive.
-(hyphen) Collapses the selected directory.



+(plus sign) Expands selected directory.
*(asterisk) Expands the entire directory branch.
Tab of F6 Moves between the directory tree and directory contents panes and drive 
indicator.
Ctrl+Tab Moves from one directory window to another.


